UltraBB Forums Home 
Home Search search Menu menu Not logged in - Login | Register

 Moderated by: Jim
New Topic Reply Printer Friendly
Test #2 by Jim  Rate Topic 
AuthorPost
 Posted: Mon May 28th, 2018 01:10 am
  PM Quote Reply
1st Post
IMPS
Member
 

Joined: Sun May 27th, 2018
Location:  
Posts: 5
Name: 
Occupation: 
Interests: 
Status: 
Offline
Mana: 
User Gallery
one line
one point five lines
two linestwo point five lines
three lines
four lines

Last edited on Mon May 28th, 2018 08:57 pm by IMPS

Back To Top PM Quote Reply  

 Posted: Mon May 28th, 2018 01:11 am
  PM Quote Reply
2nd Post
Jim
Head Cheese


Joined: Wed Apr 11th, 2007
Location:  
Posts: 8233
Name: Jim
Occupation: Programmer
Interests: Software
Status: 
Offline
Mana: 
User Gallery
Did it work or not?

Back To Top PM Quote Reply

 Posted: Mon May 28th, 2018 01:25 am
  PM Quote Reply
3rd Post
IMPS
Member
 

Joined: Sun May 27th, 2018
Location:  
Posts: 5
Name: 
Occupation: 
Interests: 
Status: 
Offline
Mana: 
User Gallery
Basically both versions of forum (ours and UltraBB) behave the same way.On Chrome, the lines were blending.On Firefox, the lines were blending.  On Internet Explorer it worked BUTwhen we edit our old posts that were posted using Firefox, it shows up with extra characters 

See attachment


So are we SOL? 


Attachment: UltraBBTest.jpg (Downloaded 112 times)

Last edited on Mon May 28th, 2018 01:30 am by IMPS

Back To Top PM Quote Reply  

 Posted: Mon May 28th, 2018 03:42 pm
  PM Quote Reply
4th Post
Jim
Head Cheese


Joined: Wed Apr 11th, 2007
Location:  
Posts: 8233
Name: Jim
Occupation: Programmer
Interests: Software
Status: 
Offline
Mana: 
User Gallery
Are you composing in something else like word or copying and pasting from a web page? The edit should not look like that

Back To Top PM Quote Reply

 Posted: Mon May 28th, 2018 05:13 pm
  PM Quote Reply
5th Post
tomtp
Tomstreasuresforum.com


Joined: Wed Jan 18th, 2012
Location: CLARKSVILLE, Tennessee USA
Posts: 712
Name: 
Occupation: RETIRED MILITARY AND RETIRED GOVT SERVICE
Interests: METAL DETECTING
Status: 
Offline
Mana: 
User Gallery
Hope Im not butting in, but Im having no problems writing or editing posts using all browsers and or copying and pasting

Back To Top PM Quote Reply  

 Posted: Mon May 28th, 2018 08:58 pm
  PM Quote Reply
6th Post
IMPS
Member
 

Joined: Sun May 27th, 2018
Location:  
Posts: 5
Name: 
Occupation: 
Interests: 
Status: 
Offline
Mana: 
User Gallery
We are copying and pasting from emails.

Back To Top PM Quote Reply

 Posted: Mon May 28th, 2018 09:24 pm
  PM Quote Reply
7th Post
IMPS
Member
 

Joined: Sun May 27th, 2018
Location:  
Posts: 5
Name: 
Occupation: 
Interests: 
Status: 
Offline
Mana: 
User Gallery
I just did a test typing in information instead of copying and pasting.

The same thing happens. It works in Internet Explorer but blends the lines in Firefox. When editing old posts in IE extra characters still show up.

FF: Line 1Line 2Line 3Line 4Line 5

IE:
Line 1
Line 2
Line 3
Line 4
Line 5

Last edited on Mon May 28th, 2018 09:25 pm by IMPS

Back To Top PM Quote Reply  

 Posted: Mon May 28th, 2018 10:27 pm
  PM Quote Reply
8th Post
martin_wynne
Licence Holder


Joined: Sun May 25th, 2008
Location: West Of The Severn, United Kingdom
Posts: 2684
Name: 
Occupation: 
Interests: 
Status: 
Offline
Mana: 
User Gallery
Hi,

If you just want to copy and paste plain text, the best solution is to use the Quick Reply box instead of the main post editors.

The WYSIWYG editors in UltraBB run the browsers in Design Mode. There is no agreed standard on how this should work, and each browser is different. Some browsers use full CSS paragraphs for newlines, some use DIVs, some insert <BR> tags.

When it comes to the formatting for indenting, centred text, etc., it gets even more of a minefield.

I have spent hours delving into this and updating my posting editor in PHP to handle the latest versions of browsers, but it is a moving feast, I can't keep up. For example the latest version of Firefox this month has broken the Quote function. It was fine before.

There are 3rd-party editors such as CK Editor which are used on other forums and could be tried on UltraBB, but they are just as flaky. For example CK Editor fails miserably on Microsoft Edge.

Martin.

Back To Top PM Quote Reply

 Posted: Sun Jun 10th, 2018 12:43 pm
  PM Quote Reply
9th Post
sw23185
License Holder
 

Joined: Mon May 17th, 2010
Location: Virginia USA
Posts: 601
Name: 
Occupation: 
Interests: 
Status: 
Offline
Mana: 
User Gallery
For what it's worth, I've always used FF but this issue is a relatively new arrival.  They obviously broke something (or maybe finally became compliant with some obscure standard) in one of their many updates.  For the record I'm now running 60.0.1 ...

The curious thing (use your own judgement, of course :cool:) is that you can force a CR-LF by using [shift-enter] instead of just plain [enter].  This old school coder's trick is helpful if you're trying to format/edit a long post for readability.

With just [Enter] :

> Line 1> Line 2> Line 3> Line 4
With [Shift-Enter] :

> Line 1
> Line 2
> Line 3
> Line 4

Back To Top PM Quote Reply  

Current time is 03:04 pm  
UltraBB Forums > WowBB > Software Assistance > Test #2 by Jim Top



Hosting

UltraBB 1.17 Copyright © 2007-2012 Data 1 Systems, INC.
Page processed in 0.1656 seconds (8% database + 92% PHP). 24 queries executed.